Camera Hacker

: :

Add Comment | Related Links | TrackBack
Related Content

Kodak V550 reset


I just tried to upload a manipulated firmware to my Kodak V550, however, it turned out to have been a major mistake: The camera doesn�t work any more! What happened was the following:

The Kodak V550 has got a way too high image compression. So I downloaded the firmware and changed the jpeg-quantization-table. First I replaced some values with similar ones (replaced all 63-numbers in the table with 61s) and it worked fine: the image quality had improved, the compression was less aggressive, but still too aggressive for me. So I tried it again, changed the values to less than 12, which means that I copied a Fuji FinePix F10-quantization-table into the firmware. The upload went fine, but when I turned on my camera again to activate the firmware, the lights were flashing for a few seconds and the camera turned itself off again. Nothing works, I can�t connect the camera to my computer, I can�t access any menu, the screen remains black, so there�s nothing I can think of to do any more... but I think that there must be some way to reset the cameras "BIOS", no? I just don't have no idea how to do it. the camera doesn't have a reset-button, so can anyone help me?

thanx alot!

Wed, 26 Oct 2005 06:29:28 -0700

hmmm . . . never heard of a hacked firmware for the v550 before . . . Where can I find some information about this firmware?

Chieh Cheng
Wed, 26 Oct 2005 11:31:22 -0700

I made the hack myself

hacking the firmware is quite easy. However, I was told by Kodak that I had to go to a Kodak store and have it repaired, so you just don�t have got enough tries to try it out. This means, you only have one try to make it right, so it�s unlikely that you will.

I was looking in the firmware for the jpeg-quantization-table and changed it. you can see more about this on
Hacking firmware to improve image quality

I located it in my firmware by looking for a series of c-letters.
In the Hex-editor, it�s the value "63".
First, I changed all (at least I think all) Cs into As, which means into the value 61, and this worked, however, the jpeg-file was just a little bigger.
Then I entered much lower values, and this destroyed it.

The only thing you have to do in order to make the camera accept the modified firmware, is to change the file attributes. Download a file attributes changer, and then enter the values (creation date etc.) of the original firmware file.

Thu, 27 Oct 2005 09:23:30 -0700

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Related Links

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 4 + 9?
Click button only once, please!


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.